UnsupportedVersion

Feb 2, 2008 at 2:24 PM
Edited Feb 2, 2008 at 2:29 PM
I have installed the toolbox using the install from this site. I am just getting started with this tool and have written a simple app to get the wallet balance of my char. The object returned from the get wallets function indicates that i am using an unsupported version.
The Code:
int characterID = 862891259;
int userID = 256833;
string apikey = "HBRkBp2izb6jbBfQP9pdnJ7TfID5D4qx3MHF4HkSlk44YaMxO2h5qQ4bZDuNEzgX";
Dictionary<Eve.API.WalletAccountKey,Eve.API.WalletAccount> wallets = new Dictionary<Eve.API.WalletAccountKey,Eve.API.WalletAccount>();


Eve.API.EveAPI api = new Eve.API.EveAPI(userID, apikey, characterID);

Eve.API.EveAPI.Error cached = api.GetWalletBalances(false, out wallets);

Error.Text = cached.Code.ToString();

if (wallets.ContainsKey(Eve.API.WalletAccountKey.Character))
CharacterWallet.Text = walletsEve.API.WalletAccountKey.Character.Balance.ToString();
else
CharacterWallet.Text = "key not found";

What am I doing wrong ?
Jun 5, 2008 at 9:11 PM
Hi,

I tried the same. I also tried any example code but all failed. I only recive the UnsupportedVersion error from the server.
What's the problem ?

Thanks,

Roi